TriStateTuners.com :: Home of Tristate Auto Enthusiast  

Go Back TriStateTuners.com :: Home of Tristate Auto Enthusiast > Racing > Road Racing
Register Rules & Info Mark Forums Read

Notices

Reply
 
Thread Tools Display Modes
Old 06-27-2011, 10:52 PM   #21
chu
Tri-State Aficionado
 
Join Date: Jul 2008
Member #8349

 
iTrader: (0)
I'll be at trackdaze this weekend with a bunch of friends. We're all driving Evos, so anyone who comes should stop by to say hello. We'll have a tent up, and drivers from a range of experience to answer questions. Hope you guys make it out!
__________________
Philadelphia Region SCCA : #17sm
Supported by:
MotorsportPerformanceGroup.us
Club Risque
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

PeteyTurboTuned|krazyhousecutoms.com
chu is offline   Reply With Quote
Old 06-29-2011, 11:19 AM   #22
neo277
Tri-State Aficionado
 
neo277's Avatar
 
Join Date: Apr 2011
Location: lehigh valley, pa
Member #20555

My Ride:
04 wrx.

iTrader: (0)
Quote:
Originally Posted by chu View Post
I'll be at trackdaze this weekend with a bunch of friends. We're all driving Evos, so anyone who comes should stop by to say hello. We'll have a tent up, and drivers from a range of experience to answer questions. Hope you guys make it out!

cool, good to meet other tst members there
__________________
- 04 Impreza Wrx. Lots of goodies!
- 01 Mustang SVT Cobra. stock for now
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
neo277 is offline   Reply With Quote
Old 06-29-2011, 11:26 AM   #23
Nick 95 6sp
Tri-State Post Whore
 
Nick 95 6sp's Avatar
 
Join Date: Feb 2007
Location: Narberth, PA
Member #3675

My Ride:
'95 Supra Turbo 6sp

iTrader: (0)
hey z (neo277) and other guys,

Sadly, it looks like I won't be ready for this one. The last parts I need to reconnect my water cooling lines are being delivered Thursday and I doubt I can get it all hooked up and done in time to run on Friday. I don't want to use just any available "hacked up" lines since that is what led to my previous coolant leaks...it gets too damn hot around those two turbos.
__________________
Nick '95 6sp Supra
Twin GT2860's w/TiAL exhaust housings, 2X TiAL WG's and BOV's, on V-band moded HKS twin manifolds,
AEM v2, FJO w/NTK, AEM meth/water spray, GSC S1 cams, OS Giken triple clutch and Super Lock LSD, Racelogic
Nick 95 6sp is offline   Reply With Quote
Old 06-29-2011, 11:36 AM   #24
neo277
Tri-State Aficionado
 
neo277's Avatar
 
Join Date: Apr 2011
Location: lehigh valley, pa
Member #20555

My Ride:
04 wrx.

iTrader: (0)
Quote:
Originally Posted by Nick 95 6sp View Post
hey z (neo277) and other guys,

Sadly, it looks like I won't be ready for this one. The last parts I need to reconnect my water cooling lines are being delivered Thursday and I doubt I can get it all hooked up and done in time to run on Friday. I don't want to use just any available "hacked up" lines since that is what led to my previous coolant leaks...it gets too damn hot around those two turbos.
Hey Nick. that stinks man,

if you lived closer to me i'd help ya get them in Thursday night so you can run on Friday.

till next time then

Z
__________________
- 04 Impreza Wrx. Lots of goodies!
- 01 Mustang SVT Cobra. stock for now
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
neo277 is offline   Reply With Quote
Old 07-02-2011, 10:06 AM   #25
neo277
Tri-State Aficionado
 
neo277's Avatar
 
Join Date: Apr 2011
Location: lehigh valley, pa
Member #20555

My Ride:
04 wrx.

iTrader: (0)
was a great time yesterday, track daze is a great group and organized so well.

i cant wait for my next track day.

Here's a few pics my wife snapped.

[IMG][/IMG]

[IMG][/IMG]

[IMG][/IMG]
__________________
- 04 Impreza Wrx. Lots of goodies!
- 01 Mustang SVT Cobra. stock for now
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
neo277 is offline   Reply With Quote
Old 07-02-2011, 03:01 PM   #26
Nick 95 6sp
Tri-State Post Whore
 
Nick 95 6sp's Avatar
 
Join Date: Feb 2007
Location: Narberth, PA
Member #3675

My Ride:
'95 Supra Turbo 6sp

iTrader: (0)
Glad you had a good day.

I'm sorry I missed this one, but I can't wait to hit that Thunderbolt track again.
__________________
Nick '95 6sp Supra
Twin GT2860's w/TiAL exhaust housings, 2X TiAL WG's and BOV's, on V-band moded HKS twin manifolds,
AEM v2, FJO w/NTK, AEM meth/water spray, GSC S1 cams, OS Giken triple clutch and Super Lock LSD, Racelogic
Nick 95 6sp is offline   Reply With Quote
Old 07-02-2011, 03:53 PM   #27
neo277
Tri-State Aficionado
 
neo277's Avatar
 
Join Date: Apr 2011
Location: lehigh valley, pa
Member #20555

My Ride:
04 wrx.

iTrader: (0)
[QUOTE=Nick 95 6sp;2012584]Glad you had a good day.

I'm sorry I missed this one, but I can't wait to hit that Thunderbolt track again.[/Q

Thunderbolt was great. Such a nice track.

Wish I did both days : )
__________________
- 04 Impreza Wrx. Lots of goodies!
- 01 Mustang SVT Cobra. stock for now
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
neo277 is offline   Reply With Quote
Old 07-02-2011, 09:03 PM   #28
SeikenFreak
Noob-Jersey
 
SeikenFreak's Avatar
 
Join Date: Jul 2011
Member #21257

My Ride:
05 WRX STI, 03 Mach 1

iTrader: (0)
Hello

First post here. Wanted to ask you Neo if you had any issues at the track with your car? Or perhaps you talked to anyone else there running our boxer motor.

I was there on Thursday with the STI and at the very end of the 4th session my motor went. Sounds like a bearing(s). So I was unable to return the next day which is disappointing as it looks like all the Scoobs decided to only come on day 2.

I'm guessing that my issue was from oil starvation or something.

Here is the youtube video ID to the vid I posted of the last session. Had to upload in 3 parts. Also dieing to see other videos from Day 1 but so far everything is just from Day 2.

7bgS_QXihdY (can't post links yet cause I'm new. )

Oh wow and look at that you have a 01 Cobra.. I was thinking of taking my Mach but I'm now totally paranoid that any car I bring is going to blow up. Have you tracked your Cobra? Any issues with the engine?

Last edited by SeikenFreak; 07-02-2011 at 09:07 PM.
SeikenFreak is offline   Reply With Quote
Old 07-02-2011, 10:33 PM   #29
neo277
Tri-State Aficionado
 
neo277's Avatar
 
Join Date: Apr 2011
Location: lehigh valley, pa
Member #20555

My Ride:
04 wrx.

iTrader: (0)
Quote:
Originally Posted by SeikenFreak View Post
Hello

First post here. Wanted to ask you Neo if you had any issues at the track with your car? Or perhaps you talked to anyone else there running our boxer motor.

I was there on Thursday with the STI and at the very end of the 4th session my motor went. Sounds like a bearing(s). So I was unable to return the next day which is disappointing as it looks like all the Scoobs decided to only come on day 2.

I'm guessing that my issue was from oil starvation or something.

Here is the youtube video ID to the vid I posted of the last session. Had to upload in 3 parts. Also dieing to see other videos from Day 1 but so far everything is just from Day 2.

7bgS_QXihdY (can't post links yet cause I'm new. )

Oh wow and look at that you have a 01 Cobra.. I was thinking of taking my Mach but I'm now totally paranoid that any car I bring is going to blow up. Have you tracked your Cobra? Any issues with the engine?
Hey, so sorry to hear the bad news. well at least now you can do a cool rebuild and get some better parts in the motor.

i didn't have any major problems, just a slight issue.

at the last session my car started to pick up slight knock above 5k, i made a small tweak to my new water/meth rom and went back out but didn't really help too much so i backed off and just ran the track at 50% power wise and called it a day. but all in all the car ran great 3 out of the 4 sessions.

i think the car just got so hot from sitting out in the sun all day and getting so hot from the sessions it just didn't want to be run hard anymore.

i went out tonight and did some data-logging and it everything looked good.

i picked up the Cobra several months ago and love driving it, no motor issues, it runs smooth and strong, I've dyno'd it and ran it at the drag-strip several times but never a circuit track. ill probably do it after i revamp the suspension.

the stock suspension is too poo poo for me.

good luck again with your car man, stinks to hear but fix it and get back on that horse again.
__________________
- 04 Impreza Wrx. Lots of goodies!
- 01 Mustang SVT Cobra. stock for now
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

Last edited by neo277; 07-02-2011 at 10:35 PM.
neo277 is offline   Reply With Quote
Old 07-02-2011, 10:48 PM   #30
Chris B.
Tri-State Post Whore
 
Chris B.'s Avatar
 
Join Date: Jul 2009
Location: Lehigh Valley
Member #14208

My Ride:
is Sonic Blue

iTrader: (0)
Quote:
Originally Posted by SeikenFreak View Post
Hello

First post here. Wanted to ask you Neo if you had any issues at the track with your car? Or perhaps you talked to anyone else there running our boxer motor.

I was there on Thursday with the STI and at the very end of the 4th session my motor went. Sounds like a bearing(s). So I was unable to return the next day which is disappointing as it looks like all the Scoobs decided to only come on day 2.

I'm guessing that my issue was from oil starvation or something.

Here is the youtube video ID to the vid I posted of the last session. Had to upload in 3 parts. Also dieing to see other videos from Day 1 but so far everything is just from Day 2.

7bgS_QXihdY (can't post links yet cause I'm new. )
I know a few other STI owners that had the same issue at NJMP.

Quote:
Originally Posted by SeikenFreak View Post
Oh wow and look at that you have a 01 Cobra.. I was thinking of taking my Mach but I'm now totally paranoid that any car I bring is going to blow up. Have you tracked your Cobra? Any issues with the engine?
I had a 2008 Mustang GT that I did many track days with. I put over 2,500 miles on it during HPDE events. No motor issues with it. However it didn't survive hitting the wall.... twice.

I have once video of me chasing a NB Miata around thunderbolt
http://www.youtube.com/watch?v=dZHXSebFrkI

Another of me doing a clean lap of Thunderbolt
http://www.youtube.com/watch?v=hLZcCx-VuhA
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.


To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
Chris B. is offline   Reply With Quote
Old 07-02-2011, 11:04 PM   #31
SeikenFreak
Noob-Jersey
 
SeikenFreak's Avatar
 
Join Date: Jul 2011
Member #21257

My Ride:
05 WRX STI, 03 Mach 1

iTrader: (0)
Quote:
Originally Posted by neo277 View Post
Hey, so sorry to hear the bad news. well at least now you can do a cool rebuild and get some better parts in the motor.
Ehhh.. Unfortunately motor is already built. But hopefully nothing extensive was damaged. Talked to my engine guy today and he thinks it could just be a rod bearing(s). Which then hopefully the crank would just need to be replaced which he said is like $300 from the dealer and maybe a rod or two depending on the damage. And a buddy of mine works at Manley so he can probably help me out with that since its got Manley stuff in it already. Was running on low boost during the last 3 sessions.. Was maybe 15 psi.

Mod list for the motor:

Hydra 2.6 EMS
Manley Turbo-Tuff Rods
Manley 8.5:1 Pistons
Cosworth High Volume Oil Pump
Cosworth Heads
Cosworth 278/274 Cams
ARP Head Studs
Garret GT3582R .82 A/R
Tomei Expreme Unequal Length Header
PT Custom Downpipe
PT Custom Up-Pipe
Tial 44mm External Wastegate
COBB Tuning 3" Cat-Back
Aquamist HFS-5 Meth Injection (Not Hooked Up)
Perrin Front Mount Intercooler
Perrin Blow-Thru Boost Tube
Perrin Intake
Bosch 1000cc Injectors
Dual Walbro 255lph Fuel Pumps
JDM Subaru TGV Deletes
Cusco Motor & Trans Mounts
SeikenFreak is offline   Reply With Quote
Old 07-03-2011, 11:24 AM   #32
neo277
Tri-State Aficionado
 
neo277's Avatar
 
Join Date: Apr 2011
Location: lehigh valley, pa
Member #20555

My Ride:
04 wrx.

iTrader: (0)
O man, wow pretty low boost for that turbo.

Well good luck again.


Quote:
Originally Posted by SeikenFreak View Post
Ehhh.. Unfortunately motor is already built. But hopefully nothing extensive was damaged. Talked to my engine guy today and he thinks it could just be a rod bearing(s). Which then hopefully the crank would just need to be replaced which he said is like $300 from the dealer and maybe a rod or two depending on the damage. And a buddy of mine works at Manley so he can probably help me out with that since its got Manley stuff in it already. Was running on low boost during the last 3 sessions.. Was maybe 15 psi.

Mod list for the motor:

Hydra 2.6 EMS
Manley Turbo-Tuff Rods
Manley 8.5:1 Pistons
Cosworth High Volume Oil Pump
Cosworth Heads
Cosworth 278/274 Cams
ARP Head Studs
Garret GT3582R .82 A/R
Tomei Expreme Unequal Length Header
PT Custom Downpipe
PT Custom Up-Pipe
Tial 44mm External Wastegate
COBB Tuning 3" Cat-Back
Aquamist HFS-5 Meth Injection (Not Hooked Up)
Perrin Front Mount Intercooler
Perrin Blow-Thru Boost Tube
Perrin Intake
Bosch 1000cc Injectors
Dual Walbro 255lph Fuel Pumps
JDM Subaru TGV Deletes
Cusco Motor & Trans Mounts
__________________
- 04 Impreza Wrx. Lots of goodies!
- 01 Mustang SVT Cobra. stock for now
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
neo277 is offline   Reply With Quote
Old 07-05-2011, 09:44 AM   #33
oneday
Tri-State Addict
 
oneday's Avatar
 
Join Date: Jul 2007
Location: Holland
Member #5367

My Ride:
E36 M3 Coupe

iTrader: (0)
Quote:
Originally Posted by SeikenFreak View Post
Hello

First post here. Wanted to ask you Neo if you had any issues at the track with your car? Or perhaps you talked to anyone else there running our boxer motor.

I was there on Thursday with the STI and at the very end of the 4th session my motor went. Sounds like a bearing(s). So I was unable to return the next day which is disappointing as it looks like all the Scoobs decided to only come on day 2.
Quote:
Originally Posted by Chris B. View Post
I know a few other STI owners that had the same issue at NJMP.
It's not an NJMP thing, it's a Subaru thing. I know of plenty of WRXs and STIs that have spun bearings at Watkins Glen, Summit, Pocono and VIR. You have to be extremely diligent at watching oil temps and pressure levels and of checking the dipstick between each session.

Friday was a nice day...a bit crowded, but not too bad. Worst part was I didn't get more than six laps before an oil line blew on the Integra--the guys who had the car there Thursday busted an axle, replaced it and in the process damaged the oil line (no idea how yet)--and I had to pull in...between two actual students (silver WRX wagon and white [?] BMW 135) and helping to coach a friend (black E30) I didn't work on the car at all and had it on the trailer after lunch.

I got one session on track in the E30 and even though I didn't feel comfortable in it (fading brakes, still tweaking suspension settings) I remembered why I like those cars so much....it didn't hurt that this particular E30 had the complete drive train from a 2000 Z3 for added power.
__________________
Saving for more track time.
oneday is offline   Reply With Quote
Old 07-06-2011, 05:04 PM   #34
McVicker
Tri-State Aficionado
 
McVicker's Avatar
 
Join Date: Aug 2008
Location: Wilmington
Member #8418

My Ride:
94 Mazda Rx-7 x2

iTrader: (0)
Send a message via AIM to McVicker
Ah that was you with the red integra? You were parked pretty much right next to us. That black E30 looked sick!! I've riden in a spec E30 car on track and it seemed like a blast to drive......


Here's a lap from one of my sessions....Blue group was definitely crowded, didn't really get any clean laps.

http://www.youtube.com/watch?v=5MBvGblU9Ks
__________________
Dan
'94 FD3S Silverstone PEP: 420whp @ 15psi "Clunkers"
'94 FD3S BB R2: 0whp @ 0psi "Pirate Hooker"

Last edited by McVicker; 07-06-2011 at 05:07 PM.
McVicker is offline   Reply With Quote
Old 07-06-2011, 09:38 PM   #35
chu
Tri-State Aficionado
 
Join Date: Jul 2008
Member #8349

 
iTrader: (0)
Quote:
Originally Posted by SeikenFreak View Post
Hello

First post here. Wanted to ask you Neo if you had any issues at the track with your car? Or perhaps you talked to anyone else there running our boxer motor.

I was there on Thursday with the STI and at the very end of the 4th session my motor went. Sounds like a bearing(s). So I was unable to return the next day which is disappointing as it looks like all the Scoobs decided to only come on day 2.

I'm guessing that my issue was from oil starvation or something.

Here is the youtube video ID to the vid I posted of the last session. Had to upload in 3 parts. Also dieing to see other videos from Day 1 but so far everything is just from Day 2.

7bgS_QXihdY (can't post links yet cause I'm new. )

Oh wow and look at that you have a 01 Cobra.. I was thinking of taking my Mach but I'm now totally paranoid that any car I bring is going to blow up. Have you tracked your Cobra? Any issues with the engine?
You must have been the guy my buddy Thai was instructing, running the green group? Fix that thing and come back out dude. I was the one in the black evo with the Club Risque stickers.
__________________
Philadelphia Region SCCA : #17sm
Supported by:
MotorsportPerformanceGroup.us
Club Risque
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

PeteyTurboTuned|krazyhousecutoms.com
chu is offline   Reply With Quote
Old 07-07-2011, 08:53 AM   #36
oneday
Tri-State Addict
 
oneday's Avatar
 
Join Date: Jul 2007
Location: Holland
Member #5367

My Ride:
E36 M3 Coupe

iTrader: (0)
Quote:
Originally Posted by McVicker View Post
Ah that was you with the red integra? You were parked pretty much right next to us. That black E30 looked sick!! I've riden in a spec E30 car on track and it seemed like a blast to drive......


Here's a lap from one of my sessions....Blue group was definitely crowded, didn't really get any clean laps.

http://www.youtube.com/watch?v=5MBvGblU9Ks
Yup. that was me with the sad face all day.

That E30 was hardly a SpecE30--those are predictable, easy to drive, and handle pretty well, where as this thing liked to wallow through corners; massive entry understeer followed by huge amounts of corner exit/throttle on oversteer. Hopefully the changes I suggested and that are being made help balance it out for his next event.

Nice lap...I can't believe how quickly that built speed down the front stretch! The 135is I instructed in the blue group only touched about 125ish on the straight...but his entry onto the straight was never quite right either.
__________________
Saving for more track time.
oneday is offline   Reply With Quote
Old 07-07-2011, 11:59 AM   #37
McVicker
Tri-State Aficionado
 
McVicker's Avatar
 
Join Date: Aug 2008
Location: Wilmington
Member #8418

My Ride:
94 Mazda Rx-7 x2

iTrader: (0)
Send a message via AIM to McVicker
haha, that E30 sounds like it's definitely got some suspension issues that need to be worked out.....at least it looked nice ;)

Thanks! The car can do a hair over 140 on the front straight when I wind it all the way out. I always like to get feedback on my laps, weather it's positive or negative I'm always opened to advice from experienced drivers

-Dan
__________________
Dan
'94 FD3S Silverstone PEP: 420whp @ 15psi "Clunkers"
'94 FD3S BB R2: 0whp @ 0psi "Pirate Hooker"
McVicker is offline   Reply With Quote
Old 07-07-2011, 04:30 PM   #38
oneday
Tri-State Addict
 
oneday's Avatar
 
Join Date: Jul 2007
Location: Holland
Member #5367

My Ride:
E36 M3 Coupe

iTrader: (0)
Quote:
Originally Posted by McVicker View Post
haha, that E30 sounds like it's definitely got some suspension issues that need to be worked out.....at least it looked nice ;)

Thanks! The car can do a hair over 140 on the front straight when I wind it all the way out. I always like to get feedback on my laps, weather it's positive or negative I'm always opened to advice from experienced drivers

-Dan
Well, if you want critique:
If you gave up a little more speed entering 3 (chicane) you could get on the power sooner...making up more ground on the short chute...then just lift a little for 4, use all the track (which you didn't do there), then get back all the way to the right (you start your turn in for 5 in the middle of the track) for a hard brake into 5. Your line though the octopus is nice and tidy, nicely done. Do you need to lift for 14 (or whatever the last turn is)? I'm pretty sure that if you turned in at the right time you could make that stick with your foot to the floor.

Over all you are clearly quick--but with a few tweaks you could be faster.
__________________
Saving for more track time.
oneday is offline   Reply With Quote
Old 07-07-2011, 04:48 PM   #39
oneday
Tri-State Addict
 
oneday's Avatar
 
Join Date: Jul 2007
Location: Holland
Member #5367

My Ride:
E36 M3 Coupe

iTrader: (0)
Correction: Your line through 4-5 is probably good for your car.

Production car fast lap on Thunderbolt
__________________
Saving for more track time.
oneday is offline   Reply With Quote
Old 07-11-2011, 08:28 PM   #40
McVicker
Tri-State Aficionado
 
McVicker's Avatar
 
Join Date: Aug 2008
Location: Wilmington
Member #8418

My Ride:
94 Mazda Rx-7 x2

iTrader: (0)
Send a message via AIM to McVicker
Thanks for the advice, definitely appreciated Sent you a PM. I was there the weekend the ACR broke the record...I've been looking for that video!
__________________
Dan
'94 FD3S Silverstone PEP: 420whp @ 15psi "Clunkers"
'94 FD3S BB R2: 0whp @ 0psi "Pirate Hooker"

Last edited by McVicker; 07-11-2011 at 08:31 PM.
McVicker is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
Following an E30 M3 Around NJMP Thunderbolt Chris B. Gallery 2 06-15-2010 03:25 PM
PCA Track Day @ NJMP BlackTypeR Gallery 10 03-24-2010 02:40 PM
Sat and Sun at NJMP DILYSIracing New Jersey 0 11-11-2009 12:30 PM
my boosted z06 @ NJMP alwaysinboost Road Racing 18 06-26-2009 12:09 PM
NJMP Pic bluengoldsti Gallery 13 05-05-2009 04:10 PM


All times are GMT -4. The time now is 04:27 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2024, vBulletin Solutions Inc.