TriStateTuners.com :: Home of Tristate Auto Enthusiast  

Go Back TriStateTuners.com :: Home of Tristate Auto Enthusiast > Tech > Asian > Mitsubishi Talk
JSC Speed
Register Rules & Info Mark Forums Read

Notices

Reply
 
Thread Tools Display Modes
Old 06-16-2008, 04:33 AM   #1
Tru2Blu
Tri-State Addict
 
Tru2Blu's Avatar
 
Join Date: Dec 2005
Location: Hamilton
Member #1214

My Ride:
02 Mazda Millenia

iTrader: (1)
Send a message via AIM to Tru2Blu Send a message via MSN to Tru2Blu Send a message via Yahoo to Tru2Blu
help car wont start!!!

while drivin the car yesterday, i was in first gear and about to go to second when the car jerked. i heard a loud pop and the car died. now its cranking, but wont turn over. any have any ideas? when i looked under the hood, the stock bov was off a little, guess the clamp did not hold it in tight enough. what could this be?
__________________
Quest for a 500awhp daily driven vr4....
Tru2Blu is offline   Reply With Quote
Old 06-16-2008, 05:52 AM   #2
sherwood
Tri-State Post Whore
 
sherwood's Avatar
 
Join Date: Jul 2006
Location: NJ
Member #2221

My Ride:
arggg 32, vr jetta.

iTrader: (0)
Send a message via AIM to sherwood
check for air..fuel..spark..go from there.
__________________
666family
Off Topic MONSTER
.dub cult.
Quote:
But I am sure the exhaust is angled for back pressure to have a faster spool-up for larger size turbochargers @ low RPM
sherwood is offline   Reply With Quote
Old 06-16-2008, 06:51 AM   #3
JKrome
Tri-State Aficionado
 
JKrome's Avatar
 
Join Date: May 2008
Location: Alexandria DC
Member #7763

My Ride:
97 Eclipse

iTrader: (0)
Send a message via AIM to JKrome
sounds like a vaccume or airline problem
__________________

To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.
DON'T DSM HATE
To view links or images in signatures your post count must be 10 or greater. You currently have 0 signatures.

97 Eclipse RS (soon to be RS-T)
07 Kawasaki ZZR600
Quote:
yoooo andrew got the 240 running i cant wait to slide that bitch!!!
JKrome is offline   Reply With Quote
Old 06-16-2008, 06:59 AM   #4
Tru2Blu
Tri-State Addict
 
Tru2Blu's Avatar
 
Join Date: Dec 2005
Location: Hamilton
Member #1214

My Ride:
02 Mazda Millenia

iTrader: (1)
Send a message via AIM to Tru2Blu Send a message via MSN to Tru2Blu Send a message via Yahoo to Tru2Blu
well i put the bov bacc on, it still did not start. and this **** has so many vaccuum lines. so ill checc those
__________________
Quest for a 500awhp daily driven vr4....
Tru2Blu is offline   Reply With Quote
Old 06-16-2008, 08:53 AM   #5
Jeffros Spec V
Tri-State Post Whore
 
Join Date: Mar 2005
Location: Langhorne PA
Member #263

 
iTrader: (0)
Send a message via AIM to Jeffros Spec V
What kind of car is this? If I recall you have a WRX and a front mount? Sounds like you blew an innercooler pipe. Check all your couplers.
Jeffros Spec V is offline   Reply With Quote
Old 06-16-2008, 09:41 AM   #6
Tru2Blu
Tri-State Addict
 
Tru2Blu's Avatar
 
Join Date: Dec 2005
Location: Hamilton
Member #1214

My Ride:
02 Mazda Millenia

iTrader: (1)
Send a message via AIM to Tru2Blu Send a message via MSN to Tru2Blu Send a message via Yahoo to Tru2Blu
Quote:
Originally Posted by Jeffros Spec V View Post
What kind of car is this? If I recall you have a WRX and a front mount? Sounds like you blew an innercooler pipe. Check all your couplers.
nah i got a 3000gt. i checc'd the vaccum lines and i took the maf sensor off and tried to start it, and nothing, so i think its either spark or fuel. dont have the resources to checc those so now i gotta wait for ground zero to tow it to his shop.
__________________
Quest for a 500awhp daily driven vr4....
Tru2Blu is offline   Reply With Quote
Old 06-16-2008, 06:14 PM   #7
VvStingervV
Tri-State Training Wheels
 
VvStingervV's Avatar
 
Join Date: Apr 2008
Location: Croydon, PA
Member #7398

My Ride:
91 Stealth TT

iTrader: (0)
Quote:
Originally Posted by Tru2Blu View Post
nah i got a 3000gt. i checc'd the vaccum lines and i took the maf sensor off and tried to start it, and nothing, so i think its either spark or fuel. dont have the resources to checc those so now i gotta wait for ground zero to tow it to his shop.
Thats your best bet if they sold it to you, let them check it out. MAF shouldn't prevent it from running, just make it idle like sh*t. Its most likely related to one or more of the problems you listed in the other thread. The Y-Pipe popping off is fairly common, just make sure its securely clamped on the throttlebody. Can you hear your fuel pump activate when you turn the key on? You can look at your coils and see if any of them look burnt or otherwise damaged. Check your plugs and wires for the same. You can pull one of the timing belt covers and watch as it cranks to make sure theres no damage to it. Hows your oil level?
__________________
1991 Mystichrome Stealth R/T Twin Turbo
Installed Mods: K&N, Gutted Precats, Downpipe w/Test Pipe, Borla Catback, MSD Wires, NGK Platinums, Solid Shifter Bushings, HKS SSQV, Stage 3 Clutch, 18" Moda R6's

Last edited by VvStingervV; 06-16-2008 at 06:16 PM.
VvStingervV is offline   Reply With Quote
Old 06-16-2008, 06:54 PM   #8
Tru2Blu
Tri-State Addict
 
Tru2Blu's Avatar
 
Join Date: Dec 2005
Location: Hamilton
Member #1214

My Ride:
02 Mazda Millenia

iTrader: (1)
Send a message via AIM to Tru2Blu Send a message via MSN to Tru2Blu Send a message via Yahoo to Tru2Blu
The other day i took the timing belt cover off, and was shocked at what i saw. A piece of metal was bent into a hole in the cover, and sitting on the timing belt, it was slowly eating away at the belt. I almost **** myself when i saw it.

But to answer your question, i dont hear the fuel pump activating, and i looked at the plugs and wires and they looked fine. as for the oil level, it never sits still. one minute it sits at half, sometimes below, sometimes above. Im waiting for GZP to get a tow trucc to picc it up and he will be addressing every issue on that list before i get the car bacc. Its just a pain in the A55 getting in touch with him.
__________________
Quest for a 500awhp daily driven vr4....
Tru2Blu is offline   Reply With Quote
Old 06-17-2008, 02:42 PM   #9
Hans_GZP
Tri-State Aficionado
 
Hans_GZP's Avatar
 
Join Date: Dec 2006
Location: Easton, PA
Member #3230

My Ride:
94 Dodge Stealth Turbo

iTrader: (2)
yea, it's hard to get a hold of me. You aren't the only one making phone calls to me. I've been away from the shop for 3 weeks. I'll get to your car ASAP, but I do have cars scheduled ahead of your's. Sorry for being hard to get a hold of, but I can't always stop what I'm doing to answer the phone or I will never get anything done. Your best bet is to leave me a message and I will call you as soon as I get a chance.
__________________
94 Dodge Stealth Turbo never ending project
91 Mitsu 3000GT full restoration
96 Mitsu 3000GT Spyder SL
92 Galant VR4 FOR SALE
96 Montero SR
Hans_GZP is offline   Reply With Quote
Old 06-17-2008, 03:47 PM   #10
Tru2Blu
Tri-State Addict
 
Tru2Blu's Avatar
 
Join Date: Dec 2005
Location: Hamilton
Member #1214

My Ride:
02 Mazda Millenia

iTrader: (1)
Send a message via AIM to Tru2Blu Send a message via MSN to Tru2Blu Send a message via Yahoo to Tru2Blu
Quote:
Originally Posted by Hans_GZP View Post
yea, it's hard to get a hold of me. You aren't the only one making phone calls to me. I've been away from the shop for 3 weeks. I'll get to your car ASAP, but I do have cars scheduled ahead of your's. Sorry for being hard to get a hold of, but I can't always stop what I'm doing to answer the phone or I will never get anything done. Your best bet is to leave me a message and I will call you as soon as I get a chance.
Cool by me, but i did leave messages. Thats neither here nor there, cuz we making progress. I got intouch with your tow dude, and he will be picc'n up the car tonight around 8 or so. As for what needs to be fixed, i dont care how long you hold on to the car, as long as its all good once returned. (and does not take a year. lol ) But keep in mind it is my only car. And you got my number, so you can keep me updated even if its just a text. Again thanks for taking care of these issues.

PS: There will be an HKS BOV in the glove box, you can hold on to it till i get the flange.
__________________
Quest for a 500awhp daily driven vr4....
Tru2Blu is offline   Reply With Quote
Reply

Bookmarks

Thread Tools
Display Modes

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off


Similar Threads
Thread Thread Starter Forum Replies Last Post
wont start. elipsekid General Car Related Chat 7 07-05-2009 06:40 PM
car wont start!!! outlawzxblizz99 Engine Performance 3 08-29-2008 07:38 AM
Need some help here, car wont start spoolinSTi Engine Performance 11 02-19-2007 10:52 PM
Need some help here, car wont start spoolinSTi Honda / Acura Talk 2 02-18-2007 09:16 PM
help! my car wont start drew General Car Related Chat 20 11-22-2006 09:51 AM


All times are GMT -4. The time now is 05:53 AM.


Powered by vBulletin® Version 3.8.11
Copyright ©2000 - 2019, vBulletin Solutions Inc.